• [gentoo-user-fr] elibtoolize Portage patch requested, but failed to app

    From Erwan RIGOLLOT@21:1/5 to All on Mon Mar 27 13:40:02 2017
    Bonjour à tous,

    Je viens de faire un emerge -sync et une mise à jour de portage sur deux gentoo.

    Certain package ne veulent plus se compiler.

    Exemples

    gcc :
    * updating multilib directories to be: ../lib64 ../lib32
    * Running elibtoolize in: gcc-4.9.4/

    * Portage patch requested, but failed to apply!
    * Please file a bug report to add a proper patch.
    * ERROR: sys-devel/gcc-4.9.4::gentoo failed (prepare phase):
    * Portage patch requested, but failed to apply!


    php-5.6.30 :
    Running elibtoolize in: apr-1.5.2/build/

    * Portage patch failed to apply (ltmain.sh version 2.4.6)!
    * Please file a bug report to add a proper patch.
    * ERROR: dev-libs/apr-1.5.2::gentoo failed (prepare phase):
    * Portage patch failed to apply!
    *
    * Call stack:
    * ebuild.sh, line 115: Called src_prepare
    * environment, line 2726: Called eautoreconf
    * environment, line 864: Called elibtoolize '--force' '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'
    * environment, line 1116: Called die
    * The specific snippet of code:
    * die "Portage patch failed to apply!";
    *
    * If you need support, post the output of `emerge --info '=dev-libs/apr-1.5.2::gentoo'`,
    * the complete build log and the output of `emerge -pqv '=dev-libs/apr-1.5.2::gentoo'`.
    * The complete build log is located at '/var/tmp/portage/dev-libs/apr-1.5.2/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-libs/apr-1.5.2/temp/environment'.
    * Working directory: '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'
    * S: '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'


    J'ai tenté beaucoup de chose sans succès.

    Quelqu'un a une idée de ce que je pourrais faire ?

    Merci

    <html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <meta name="Generator" content="Microsoft Word 15 (filtered medium)"> <style><!--
    /* Font Definitions */
    @font-face
    {font-family:"Cambria Math";
    panose-1:2 4 5 3 5 4 6 3 2 4;}
    @font-face
    {font-family:Calibri;
    panose-1:2 15 5 2 2 2 4 3 2 4;}
    /* Style Definitions */
    p.MsoNormal, li.MsoNormal, div.MsoNormal
    {margin:0cm;
    margin-bottom:.0001pt;
    font-size:11.0pt;
    font-family:"Calibri",sans-serif;
    mso-fareast-language:EN-US;}
    a:link, span.MsoHyperlink
    {mso-style-priority:99;
    color:#0563C1;
    text-decoration:underline;}
    a:visited, span.MsoHyperlinkFollowed
    {mso-style-priority:99;
    color:#954F72;
    text-decoration:underline;}
    p.msonormal0, li.msonormal0, div.msonormal0
    {mso-style-name:msonormal;
    mso-margin-top-alt:auto;
    margin-right:0cm;
    mso-margin-bottom-alt:auto;
    margin-left:0cm;
    font-size:12.0pt;
    font-family:"Times New Roman",serif;}
    span.EmailStyle18
    {mso-style-type:personal-compose;
    font-family:"Calibri",sans-serif;
    color:windowtext;}
    .MsoChpDefault
    {mso-style-type:export-only;
    font-size:10.0pt;}
    @page WordSection1
    {size:612.0pt 792.0pt;
    margin:70.85pt 70.85pt 70.85pt 70.85pt;}
    div.WordSection1
    {page:WordSection1;}
    </style><!--[if gte mso 9]><xml>
    <o:shapedefaults v:ext="edit" spidmax="1026" />
    </xml><![endif]--><!--[if gte mso 9]><xml>
    <o:shapelayout v:ext="edit">
    <o:idmap v:ext="edit" data="1" />
    </o:shapelayout></xml><![endif]-->
    </head>
    <body lang="FR" link="#0563C1" vlink="#954F72">
    <div class="WordSection1">
    <p class="MsoNormal">Bonjour à tous,<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">Je viens de faire un emerge &#8211;sync et une mise à jour de portage sur deux gentoo.<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">Certain package ne veulent plus se compiler.<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">Exemples<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">gcc&nbsp;:<o:p></o:p></p>
    <p class="MsoNormal">* updating multilib directories to be: ../lib64 ../lib32<o:p></o:p></p>
    <p class="MsoNormal">* Running elibtoolize in: gcc-4.9.4/<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">* Portage patch requested, but failed to apply!<o:p></o:p></p>
    <p class="MsoNormal">* Please file a bug report to add a proper patch.<o:p></o:p></p>
    <p class="MsoNormal">* ERROR: sys-devel/gcc-4.9.4::gentoo failed (prepare phase):<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp; Portage patch requested, but failed to apply!<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">php-5.6.30&nbsp;:<o:p></o:p></p>
    <p class="MsoNormal">Running elibtoolize in: apr-1.5.2/build/<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">* Portage patch failed to apply (ltmain.sh version 2.4.6)!<o:p></o:p></p>
    <p class="MsoNormal">* Please file a bug report to add a proper patch.<o:p></o:p></p>
    <p class="MsoNormal">* ERROR: dev-libs/apr-1.5.2::gentoo failed (prepare phase):<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp; Portage patch failed to apply!<o:p></o:p></p>
    <p class="MsoNormal">*<o:p></o:p></p>
    <p class="MsoNormal">* Call stack:<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp;&nbsp;&nbsp; ebuild.sh, line&nbsp; 115:&nbsp; Called src_prepare<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp; environment, line 2726:&nbsp; Called eautoreconf<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp; environment, line&nbsp; 864:&nbsp; Called elibtoolize '--force' '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp; environment, line 1116:&nbsp; Called die<o:p></o:p></p>
    <p class="MsoNormal">* The specific snippet of code:<o:p></o:p></p>
    <p class="MsoNormal">*&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; die &quot;Portage patch
    failed to apply!&quot;;<o:p></o:p></p>
    <p class="MsoNormal">*<o:p></o:p></p>
    <p class="MsoNormal">* If you need support, post the output of `emerge --info '=dev-libs/apr-1.5.2::gentoo'`,<o:p></o:p></p>
    <p class="MsoNormal">* the complete build log and the output of `emerge -pqv '=dev-libs/apr-1.5.2::gentoo'`.<o:p></o:p></p>
    <p class="MsoNormal">* The complete build log is located at '/var/tmp/portage/dev-libs/apr-1.5.2/temp/build.log'.<o:p></o:p></p>
    <p class="MsoNormal">* The ebuild environment file is located at '/var/tmp/portage/dev-libs/apr-1.5.2/temp/environment'.<o:p></o:p></p>
    <p class="MsoNormal">* Working directory: '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'<o:p></o:p></p>
    <p class="MsoNormal">* S: '/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">J&#8217;ai tenté beaucoup de chose sans succès.<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">Quelqu&#8217;un a une idée de ce que je pourrais faire&nbsp;?<o:p></o:p></p>
    <p class="MsoNormal"><o:p>&nbsp;</o:p></p>
    <p class="MsoNormal">Merci<o:p></o:p></p>
    </div>
    </body>
    </html>

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)