• Can't find libappindicator3-1 on bullseye!

    From =?gb18030?B?tPO9q778zfU=?=@21:1/5 to All on Sun Mar 7 08:30:01 2021
    This is a multi-part message in MIME format.

    SGVsbG8sDQoNCmkgaW5zdGFsbGVkIHllc3BsYXltdXNpYyBwYWNrYWdlIHRoYXQgd2FzJm5i c3A7IGZyb20gZ2l0aHViIG9uIG15IGRlYmlhbiAxMSwgYW5kIGkgZ290IGFuIGVycm9yOiBD YW4ndCBmaW5kIHRoZSBwYWNrYWdlJm5ic3A7IGxpYmFwcGluZGljYXRvcjMtMS4NCg0KDQpJ J3ZlIGNoZWNrZWQgdGhlIHBhY2thZ2UgZnJvbSBwYWNrYWdlcy5kZWJpYW4ub3JnLCB5ZXMg aXQgaXMgaW4gYnVzdGVyLCBCVVQsIGkgY2FuJ3QgZmluZCBpdCBpbiBidWxsc2V5ZS4NCg0K DQpTbywgaG93IGNhbiBpIGRvPw0KDQoNClRoYW5rcyBhIGxvdCE=

    PG1ldGEgaHR0cC1lcXVpdj0iQ29udGVudC1UeXBlIiBjb250ZW50PSJ0ZXh0L2h0bWw7IGNo YXJzZXQ9R0IxODAzMCI+PGZvbnQgc2l6ZT0iNSIgY29sb3I9IiMwMDAwRkYiPkhlbGxvLDwv Zm9udD48ZGl2Pjxmb250IHNpemU9IjUiIGNvbG9yPSIjMDAwMEZGIj48YnI+PC9mb250Pjwv ZGl2PjxkaXY+PGZvbnQgc2l6ZT0iNSIgY29sb3I9IiMwMDAwRkYiPmkgaW5zdGFsbGVkIHll c3BsYXltdXNpYyBwYWNrYWdlIHRoYXQgd2FzJm5ic3A7IGZyb20gZ2l0aHViIG9uIG15IGRl YmlhbiAxMSwgYW5kIGkgZ290IGFuIGVycm9yOiBDYW4ndCBmaW5kIHRoZSBwYWNrYWdlJm5i c3A7IDwvZm9udD48Zm9udCBzaXplPSI1IiBjb2xvcj0iIzAwMDBGRiI+bGliYXBwaW5kaWNh dG9yMy0xLjwvZm9udD48L2Rpdj48ZGl2Pjxmb250IHNpemU9IjUiIGNvbG9yPSIjMDAwMEZG Ij48YnI+PC9mb250PjwvZGl2PjxkaXY+PGZvbnQgc2l6ZT0iNSIgY29sb3I9IiMwMDAwRkYi PkkndmUgY2hlY2tlZCB0aGUgcGFja2FnZSBmcm9tIHBhY2thZ2VzLmRlYmlhbi5vcmcsIHll cyBpdCBpcyBpbiBidXN0ZXIsIEJVVCwgaSBjYW4ndCBmaW5kIGl0IGluIGJ1bGxzZXllLjwv Zm9udD48L2Rpdj48ZGl2Pjxmb250IHNpemU9IjUiIGNvbG9yPSIjMDAwMEZGIj48YnI+PC9m b250PjwvZGl2PjxkaXY+PGZvbnQgc2l6ZT0iNSIgY29sb3I9IiMwMDAwRkYiPlNvLCBob3cg Y2FuIGkgZG8/PC9mb250PjwvZGl2PjxkaXY+PGZvbnQgc2l6ZT0iNSIgY29sb3I9IiMwMDAw RkYiPjxicj48L2ZvbnQ+PC9kaXY+PGRpdj48Zm9udCBzaXplPSI1IiBjb2xvcj0iIzAwMDBG RiI+VGhhbmtzIGEgbG90ITwvZm9udD48L2Rpdj4=

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Peter Pentchev@21:1/5 to All on Sun Mar 7 12:40:02 2021
    On Sun, Mar 07, 2021 at 03:12:23PM +0800, 大将军王 wrote:
    Hello,

    i installed yesplaymusic package that was  from github on my debian
    11, and i got an error: Can't find the package  libappindicator3-1.


    I've checked the package from packages.debian.org, yes it is in buster,
    BUT, i can't find it in bullseye.

    Hi,

    Without looking into it, it sounds like you installed an already-built
    binary package that was built for an earlier version of Debian. Well,
    with time the Debian packages change, some are renamed, some get newer versions.

    You should either contact the authors and ask them to rebuild
    the package for Debian testing/unstable, or try to build it yourself
    from source, so that it picks up the necessary dependencies and
    libraries.

    Hope that helps!

    G'luck,
    Peter

    --
    Peter Pentchev roam@ringlet.net roam@debian.org pp@storpool.com
    PGP key: http://people.FreeBSD.org/~roam/roam.key.asc
    Key fingerprint 2EE7 A7A5 17FC 124C F115 C354 651E EFB0 2527 DF13

    -----BEGIN PGP SIGNATURE-----

    iQIzBAABCgAdFiEELuenpRf8EkzxFcNUZR7vsCUn3xMFAmBEuQAACgkQZR7vsCUn 3xPhhQ//UFEIlqYehSEyd/sOpEThGYSyB9OSqCr7Wu96fmcvPhQhWcaZKx5FH0Gn dSUG4TKiEnnLjvB/LlnEKXskrRRs0oqVwPjnuZQD328Po/igCOBWzAzDOTvSmDAX AE0F/oVxF8OWv+4BSq9QTd9p9daFtPrKvSXA0//u1+LfVKb3f2aqsXbwl8Q95Nn5 zDFOyihsD/9IsYe6mQq00mbAEO/3gSkxq4f52/RMs9+rnHZi2Z2WZk0eEcWk6SVX pxIj5gb16/tzm9E+Xc2LEdfzd10AIx41krL/NuZJtEIIFpXrfCVFq8Gs0xVY4E8T +PTSSXRMjOwmVX4wqZOHjyp8Y5vUFAhGUiYRaKhHcXwjb39foN6rcsXJwzhMBKh3 9d+hISScwz/5eFjnjzNeAxE7MkeCvPZbl6RruQtMZwQnmrkBnEuorBBuikdTuMpU xxWjmCdBjnNCv61VrpTRN29b155Iw1TUMlUY3Cti5eOUkD4VUUYvvsmqOqD+cDde mioY+EGaxw5WeXktu+7G3+qWEHpDROKpXyG9ldsPkrwqnZlPoLhzhXPsR0AqR9zi MlxFBeigEXD3Kkw9eE9dIByaJvFgmSbraI1ufIka3Z+I0/wuFyT2rJio17IO/QYq USeSubzj347NAQVXTLl+T2K52Z99Iv/Ok7kCTbBbqB6Vda3GIb8=
    =Qzsz
    -
  • From Adrian D'Costa@21:1/5 to roam@ringlet.net on Thu Apr 29 08:20:01 2021
    Read the following website:

    https://github.com/vector-im/element-web/issues/16174

    It suggests to install libappindicator from Debian stretch using dpkg -i package name.deb. Hope it helps.

    Cheers
    Adrian

    On Sun., Mar. 7, 2021, 6:37 a.m. Peter Pentchev, <roam@ringlet.net> wrote:

    On Sun, Mar 07, 2021 at 03:12:23PM +0800, 大将军王 wrote:
    Hello,

    i installed yesplaymusic package that was&nbsp; from github on my debian 11, and i got an error: Can't find the package&nbsp; libappindicator3-1.


    I've checked the package from packages.debian.org, yes it is in buster, BUT, i can't find it in bullseye.

    Hi,

    Without looking into it, it sounds like you installed an already-built
    binary package that was built for an earlier version of Debian. Well,
    with time the Debian packages change, some are renamed, some get newer versions.

    You should either contact the authors and ask them to rebuild
    the package for Debian testing/unstable, or try to build it yourself
    from source, so that it picks up the necessary dependencies and
    libraries.

    Hope that helps!

    G'luck,
    Peter

    --
    Peter Pentchev roam@ringlet.net roam@debian.org pp@storpool.com
    PGP key: http://people.FreeBSD.org/~roam/roam.key.asc
    Key fingerprint 2EE7 A7A5 17FC 124C F115 C354 651E EFB0 2527 DF13


    <div dir="auto">Read the following website:<div dir="auto"><br></div><div dir="auto"><a href="https://github.com/vector-im/element-web/issues/16174">https://github.com/vector-im/element-web/issues/16174</a><br></div><div dir="auto"><br></div><div dir="
    auto">It suggests to install libappindicator from Debian stretch using dpkg  -i package name.deb. Hope it helps.</div><div dir="auto"><br></div><div dir="auto">Cheers</div><div dir="auto">Adrian</div></div><br><div class="gmail_quote"><div dir="ltr"
    class="gmail_attr">On Sun., Mar. 7, 2021, 6:37 a.m. Peter Pentchev, &lt;<a href="mailto:roam@ringlet.net">roam@ringlet.net</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On
    Sun, Mar 07, 2021 at 03:12:23PM +0800, 大将军王 wrote:<br>
    &gt; Hello,<br>
    &gt; <br>
    &gt; i installed yesplaymusic package that was&amp;nbsp; from github on my debian<br>
    &gt; 11, and i got an error: Can&#39;t find the package&amp;nbsp; libappindicator3-1.<br>
    &gt; <br>
    &gt; <br>
    &gt; I&#39;ve checked the package from <a href="http://packages.debian.org" rel="noreferrer noreferrer" target="_blank">packages.debian.org</a>, yes it is in buster,<br>
    &gt; BUT, i can&#39;t find it in bullseye.<br>

    Hi,<br>

    Without looking into it, it sounds like you installed an already-built<br> binary package that was built for an earlier version of Debian. Well,<br>
    with time the Debian packages change, some are renamed, some get newer<br> versions.<br>

    You should either contact the authors and ask them to rebuild<br>
    the package for Debian testing/unstable, or try to build it yourself<br>
    from source, so that it picks up the necessary dependencies and<br> libraries.<br>

    Hope that helps!<br>

    G&#39;luck,<br>
    Peter<br>

    -- <br>
    Peter Pentchev  <a href="mailto:roam@ringlet.net" target="_blank" rel="noreferrer">roam@ringlet.net</a> <a href="mailto:roam@debian.org" target="_blank" rel="noreferrer">roam@debian.org</a> <a href="mailto:pp@storpool.com" target="_blank" rel="
    noreferrer">pp@storpool.com</a><br>
    PGP key:        <a href="http://people.FreeBSD.org/~roam/roam.key.asc" rel="noreferrer noreferrer" target="_blank">http://people.FreeBSD.org/~roam/roam.key.asc</a><br>
    Key fingerprint 2EE7 A7A5 17FC 124C F115  C354 651E EFB0 2527 DF13<br> </blockquote></div>

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)