• DRDA IBM i to z/OS

    From Mike Colangelo@21:1/5 to All on Tue Sep 4 19:21:46 2018
    I'm working on a proof-of-concept for a client. They want an embedded
    SQL program (CBLLE or RPGLE) to connect to a z/OS DB2 instance, read
    data from a table and bring it back to the IBM i.

    I wrote the IBM i program (ILE COBOL), successful connected to the z/OS
    DB2, and attempted to open a cursor on a remote table. I got a failure
    code because of no package. On the IBM i side, I eventually was
    seemingly able to create a package on z/OS by using CRTSQLPKG and
    specifying the IBM i program and the z/OS remote database name.

    When I tried running the program again, I got a different error when I attempted to open the cursor. This time, the error indicated the z/OS
    user ID that made the connection was not authorized to the SQL package.
    That's odd, because the same user ID was used via a server authorization
    entry when I ran the CRTSQLPKG command.

    At my last job, I helped to make this happen going to the other
    direction: COBOL program on z/OS making connection to IBM i and reading
    data from IBM i DB2 tables using SQL. The mainframe developers had some initial trouble with their BINDs, but eventually we got it to work.

    Does anyone here have any experience connecting _from_ IBM i _to_ z/OS?
    If so, do you have any tips, and can you point me to any IBM
    documentation on this?

    Thanks in advance.

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)