• FireFox38 pegging CPU Usage

    From PaulRS@21:1/5 to All on Thu Oct 1 17:39:36 2015
    XPost: comp.os.os2.misc

    I have noticed on certain sites, the newest OS/2 Firefox 38 slows way
    down pegging the CPU usage at 100%. I tried the same sites on an
    up-to-date Firefox under Win7 and this does not happen.

    (1) Question 1: Does anyone know the reason for this?

    (2) Question 2: Is there any user adjustments in Firefox 38 that can
    be adjusted/changed to help limit this inconvenience?

    Thanks in Advance for any input.

    Paul
    --

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Marcel Mueller@21:1/5 to PaulRS on Thu Oct 1 23:15:48 2015
    XPost: comp.os.os2.misc

    On 01.10.15 19.39, PaulRS wrote:
    I have noticed on certain sites, the newest OS/2 Firefox 38 slows way
    down pegging the CPU usage at 100%. I tried the same sites on an
    up-to-date Firefox under Win7 and this does not happen.

    Just guessing...

    The OS/2 memory management functions of the runtime library (operator
    new, operator delete ...) do not scale properly for heavy OOP usage.
    I already noticed this in another project.


    (2) Question 2: Is there any user adjustments in Firefox 38 that can
    be adjusted/changed to help limit this inconvenience?

    Probably not if the above assumption proves true.

    But limiting JavaScript and using a light ad blocker like ÁBlock can
    reduce the problem sometimes.


    Marcel

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Dave Yeo@21:1/5 to PaulRS on Thu Oct 1 18:03:45 2015
    XPost: comp.os.os2.misc

    PaulRS wrote:
    I have noticed on certain sites, the newest OS/2 Firefox 38

    Do you mean 31.8.0? 38 is still under development and as far as I know
    not actually working on OS/2 yet.

    slows way
    down pegging the CPU usage at 100%. I tried the same sites on an
    up-to-date Firefox under Win7 and this does not happen.

    (1) Question 1: Does anyone know the reason for this?

    Is plugin-container.exe running at the time of 100% CPU? Do you have
    Flash installed?


    (2) Question 2: Is there any user adjustments in Firefox 38 that can
    be adjusted/changed to help limit this inconvenience?

    For Flash, you can go to about:addons and under plugins set Flash to
    always ask to be activated.
    If plugin-container is actually running, you need to set some
    preferences to disable OOP
    Marcel's idea of using an adblocker is a good one. I use no-script to
    avoid situations such as you describe.


    Thanks in Advance for any input.

    Paul


    Dave

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From PaulRS@21:1/5 to All on Fri Oct 2 05:01:09 2015
    XPost: comp.os.os2.misc

    On Fri, 2 Oct 2015 01:03:45 UTC, Dave Yeo <dave.r.yeo@gmail.com>
    wrote:

    PaulRS wrote:
    I have noticed on certain sites, the newest OS/2 Firefox 38

    Do you mean 31.8.0? 38 is still under development and as far as I know
    not actually working on OS/2 yet.

    slows way
    down pegging the CPU usage at 100%. I tried the same sites on an up-to-date Firefox under Win7 and this does not happen.

    (1) Question 1: Does anyone know the reason for this?

    Is plugin-container.exe running at the time of 100% CPU? Do you have
    Flash installed?


    (2) Question 2: Is there any user adjustments in Firefox 38 that can
    be adjusted/changed to help limit this inconvenience?

    For Flash, you can go to about:addons and under plugins set Flash to
    always ask to be activated.
    If plugin-container is actually running, you need to set some
    preferences to disable OOP
    Marcel's idea of using an adblocker is a good one. I use no-script to
    avoid situations such as you describe.


    Thanks in Advance for any input.

    Paul


    Dave

    I mean Forefox 31.8. My Flashplayer is 11.5 r502. It was set at
    "Always Activate" so I set it to "Ask to Activate"

    Not sure what is meant by: > If plugin-container is actually running,
    you need to set some
    preferences to disable OOP

    Paul
    --

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Dave Yeo@21:1/5 to PaulRS on Thu Oct 1 23:03:23 2015
    XPost: comp.os.os2.misc

    PaulRS wrote:
    On Fri, 2 Oct 2015 01:03:45 UTC, Dave Yeo <dave.r.yeo@gmail.com>
    wrote:

    PaulRS wrote:
    I have noticed on certain sites, the newest OS/2 Firefox 38

    Do you mean 31.8.0? 38 is still under development and as far as I know
    not actually working on OS/2 yet.

    slows way
    down pegging the CPU usage at 100%. I tried the same sites on an
    up-to-date Firefox under Win7 and this does not happen.

    (1) Question 1: Does anyone know the reason for this?

    Is plugin-container.exe running at the time of 100% CPU? Do you have
    Flash installed?


    (2) Question 2: Is there any user adjustments in Firefox 38 that can
    be adjusted/changed to help limit this inconvenience?

    For Flash, you can go to about:addons and under plugins set Flash to
    always ask to be activated.
    If plugin-container is actually running, you need to set some
    preferences to disable OOP
    Marcel's idea of using an adblocker is a good one. I use no-script to
    avoid situations such as you describe.


    Thanks in Advance for any input.

    Paul


    Dave

    I mean Forefox 31.8. My Flashplayer is 11.5 r502. It was set at
    "Always Activate" so I set it to "Ask to Activate"

    Good chance that will help. Flash really needs to be updated for FF
    31.8.0 and newer but as it is going away it probably won't be fixed.
    Always a good idea to keep the use of our old Flash to a minimum, if
    only due to all the vulnerabilities in it.


    Not sure what is meant by: > If plugin-container is actually running,
    you need to set some
    preferences to disable OOP

    Use top or such to see if the process using all your CPU is actually plugin-container.exe. Assuming you are using the latest FF, it shouldn't
    be a problem.

    Dave

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)