• Problem with hardware running debian and ubuntu

    From kernelbt@gmail.com@21:1/5 to All on Fri Dec 1 07:52:17 2017
    I have been running ubuntu on an intel machine but in recent times it became unstable. I believe it's a hardware problem. I tried installing debian but I still got some sort of hardware error. I assume it is a hardware error. I took a picture of the
    stack trace and uploaded it here:


    Does this look like a hardware issue or something else?

    Thank you

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From J G Miller@21:1/5 to Kernel BT on Fri Dec 1 16:55:52 2017
    On Friday, December 1st, 2017, at 07:52:17h -0800, Kernel BT asked:

    Does this look like a hardware issue or something else?

    Maybe, maybe not.

    System messages which directly indicate a hardware problem are those
    related to hard disk problems (viz bad sectors and related).

    Random kernel crashes could be due to software corruption or memory
    problems, the latter being more probable if you are using a distribution supplied kernel without any other modules with binary blobs supplied
    by third parties.

    So the best course of action (which I had to do to finally resolve
    random crashes due to running memory sticks at their rated speed supposed to
    be supported by the motherboard in memory overclocking mode but actually only worked at the standard [at time of manufacture] memory speed of the motherboard)
    is to

    1) remove all of your memory sticks

    2) insert one memory stick at a time in the same memory slot
    and run memtest (from the grub prompt)

    3) then try two together and run memtest

    4) after iterations of the above in different slots and no errors
    reported, then try memtest with all of them inserted together

    Do not do these test with any overclocking feature but all at the
    standard speeds/voltages rated for the motherboard.

    Sometimes just re=seating the memory sticks can solve the problem.

    Either you will find memtest fails on some test with some particular combination of memory sticks and slots or your problem lies elsewhere.

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)