• multipart/mixed format messages display as blank in message reader

    From rlew@amu.edu.pl@21:1/5 to All on Thu Aug 11 04:52:08 2016
    I've used Pegasus since the very early days, and today I've run into my first serious hurdle.
    My Pegasus, version 4.70en, stopped displaying certain messages which had displayed correctly up to now.
    The message opens but nothing shows in the main message window. Same in the Preview Mode. Switching views with the v key between simple and formatted view does not help.
    It seems that the messages affected are those with the
    Content-Type: multipart/mixed
    declaration in the header. By contrast,
    Content-Type: multipart/alternative;
    are displaying fine.

    I've tried in sequence the following:
    - disabling the IE Renderer mode
    - upgrading to 4.72
    - downgrading to 4.41
    - removing temporarily the filetypes.pm file and restarting
    Unfortunately, none of this has worked.

    The OS is Windows 10.
    Recently, I've been playing with system file associations for PDF files, changing the default application between Acrobat Reader, the native Reader App and Sumatra PDF. In the process, I've used the Windows Power Shell to reinstall the Windows Apps,
    because the Windows Reader stopped being recognized. Don't know if this has anything to do with the problem at hand, but this is all I can think of that's happened in the past week.

    In the messages displayed as blank I can switch into the Raw view and Attachments view. In the Attachments view I'm seeing something like this:

    Multipart section
    | Plain text -
    E-mail message message Original message 4.4k
    \ Plain text - 1.5k

    I can "preview" each of these sections in the Attachments view.
    The "E-mail message" section displays the four basic headers.
    The bottom "Plain text" section displays the text of the message in plain text. I'm reporting this because one suspicion that I hold is that Pmail somehow started interpreting these messages as empty messages with everything as attachment.

    I don't want to part with Pegasus, it has served me so well for decades.

    Can anyone please offer any insights, suggestions on what to try next?


    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From rlew@amu.edu.pl@21:1/5 to All on Sat Aug 13 05:32:46 2016
    Upon closer inspection it appears that the source of the problem was a misconfiguration of the SMTP server, which, following an upgrade, occasionally included an empty MIME section for certain types of incoming messages. My thanks to the mail
    administrators of amu.edu.pl for quickly looking into the issue. The problem, then is issentially solved, and it was NOT primarily the fault of Pegasus.
    Nevertheless, I note in the passing that other email clients I use displayed the messages "correctly", i.e. the contained message rather than the empty section by default. So, perhaps David Harris will consider including a check for an empty section in
    Multipart/Mixed to deal with this kind of message in a more user-friendly fashion.

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)