• Help with remote access to X (Ingres 11.2)

    From Roy Hann@21:1/5 to All on Tue Apr 12 11:52:53 2022
    I am having no joy getting a remote connection to 11.2.

    I've installed 11.2 on a Linux box and a Windows box. I've tried
    automatic installs and manual installs.

    Ingres is up and running. I can ping the host. But I cannot get a
    connection. Testing within Netutil I get this and no more:

    +----------------------------------------------------------------------------+ | The connection to database 'nixbox::sandbox' has failed. | | | | E_GC000B_RMT_LOGIN_FAIL Login failure: invalid username/password. | | [PRESS RETURN] | +----------------------------------------------------------------------------+

    I will admit I've only skimmed the 11.2 Connectivity Guide. Nothing
    leapt out at me. I'm hoping someone will save me the trouble of
    laboriously studying it...

    Roy

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From nikosv@21:1/5 to All on Tue Apr 12 13:03:58 2022
    I remember hitting something like that and it was because of the characterset of the client and Ingres being different.
    The client was sending UTF and Ingres was setup with Greek,so the characters of username/password despite being in English were being mangled.
    After setting the correct character set (Greek) on the connection string everything was fine.

    In your case is there a case between multibyte and single byte encodings?

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From G Jones@21:1/5 to All on Tue Apr 12 23:36:16 2022
    At risk of pointing toward the more obvious settings - dbms_authentication, II_SHADOW_PWD ?

    On Linux, where I tend to install using ingbuild, I've noticed that in recent 11.1 upgrade patches you no longer get ingvalidpam automatically, which confused me for a while when I'd set II_SHADOW_PWD to a binary which didn't exist.
    There's a mkvalidpam now to set it up - but that wants root access which I might not have, so instead I grab a copy from $II_SYSTEM/ingres/files/iipwd/ingvalidpam.dis

    I'm yet to move onto 11.2 though. Things could be different there.
    GJ

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Vaclav Dohnal@21:1/5 to All on Tue Apr 12 23:20:21 2022
    Dne úterý 12. dubna 2022 v 13:52:55 UTC+2 uživatel Roy Hann napsal:
    I am having no joy getting a remote connection to 11.2.

    I've installed 11.2 on a Linux box and a Windows box. I've tried
    automatic installs and manual installs.

    Ingres is up and running. I can ping the host. But I cannot get a connection. Testing within Netutil I get this and no more:

    +----------------------------------------------------------------------------+
    | The connection to database 'nixbox::sandbox' has failed. |
    | |
    | E_GC000B_RMT_LOGIN_FAIL Login failure: invalid username/password. |
    | [PRESS RETURN] | +----------------------------------------------------------------------------+

    I will admit I've only skimmed the 11.2 Connectivity Guide. Nothing
    leapt out at me. I'm hoping someone will save me the trouble of
    laboriously studying it...

    Roy

    Hello,
    I think you have the dbms authentication turned ON. Check the cbf - dbms server - dbms_authentication. You have to restart the installation if you change it.

    Vasek

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Roy Hann@21:1/5 to Vaclav Dohnal on Wed Apr 13 08:12:24 2022
    Vaclav Dohnal wrote:

    Dne ter 12. dubna 2022v13:52:55 UTC+2 uivatel Roy Hann napsal:
    I am having no joy getting a remote connection to 11.2.

    I've installed 11.2 on a Linux box and a Windows box. I've tried
    automatic installs and manual installs.

    Ingres is up and running. I can ping the host. But I cannot get a
    connection. Testing within Netutil I get this and no more:

    +----------------------------------------------------------------------------+
    | The connection to database 'nixbox::sandbox' has failed. |
    | |
    | E_GC000B_RMT_LOGIN_FAIL Login failure: invalid username/password. |
    | [PRESS RETURN] |
    +----------------------------------------------------------------------------+

    I will admit I've only skimmed the 11.2 Connectivity Guide. Nothing
    leapt out at me. I'm hoping someone will save me the trouble of
    laboriously studying it...

    Roy

    Hello,
    I think you have the dbms authentication turned ON. Check the
    cbf - dbms server - dbms_authentication. You have to restart the
    installation if you change it.

    Thanks Vaclav. I am pleased to say I just double-checked your suggestion
    and I did not make that error. But thank you all the same.

    Roy

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Roy Hann@21:1/5 to nikosv on Wed Apr 13 08:47:53 2022
    nikosv wrote:

    I remember hitting something like that and it was because of the
    characterset of the client and Ingres being different. The client
    was sending UTF and Ingres was setup with Greek,so the characters
    of username/password despite being in English were being mangled.
    After setting the correct character set (Greek) on the connection string everything was fine.

    In your case is there a case between multibyte and single byte encodings?

    Good thought Nikos. I'd not considered that.

    I was pretty sure I'd installed all my copies of Ingres using ISO88591
    so I just did a quick check. As it turns out the Windows machine where
    I tried to create the vnode is using WIN1252, but the Linux machines are
    all using ISO88591. That windows machine has never had a problem
    connecting in the past in spite of the different character set--which is
    why I've not noticed the difference before I suppose.

    I just installed another copy of 11.2 on a second Linux box and I
    can't get the two 11.2 installations to talk to each other. I can
    connect to the remote name server but that's all.

    Roy

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)
  • From Roy Hann@21:1/5 to G Jones on Wed Apr 13 09:21:23 2022
    G Jones wrote:

    At risk of pointing toward the more obvious settings -
    dbms_authentication, II_SHADOW_PWD ?

    On Linux, where I tend to install using ingbuild, I've noticed that in
    recent 11.1 upgrade patches you no longer get ingvalidpam automatically, which confused me for a while when I'd set II_SHADOW_PWD to a binary
    which didn't exist. There's a mkvalidpam now to set it up - but that
    wants root access which I might not have, so instead I grab a copy from $II_SYSTEM/ingres/files/iipwd/ingvalidpam.dis

    I'm yet to move onto 11.2 though. Things could be different there.

    You totally nailed it Geraint!

    Manually running mkvalidpam as root then setting II_SHADOW_PWD to point
    to it makes everything work as usual.

    Add one to the list of pints I owe you.

    Roy

    --- SoupGate-Win32 v1.05
    * Origin: fsxNet Usenet Gateway (21:1/5)