• Full Sound in DOS

    From Elf@21:1/194 to ALL on Sat Jul 24 21:43:00 2021
    I am wondering if anyone might have some ideas on getting a Sound
    Blaster 16 PCI card working fully in DOS. Here is what I have and what
    I'm trying to do.

    Dell Dimension 3000, 512MB RAM
    GeForce FX 5500 256MB video card
    Windows 98SE
    Sound Blaster 16 PCI with full software/drivers

    So I am trying to play a DOS game, Commander Keen 6 for example. The
    sounds work, but not fully. For example, all the sounds as far as I know
    are working with the exception of when I die or when I jump and hit my
    head on an upper level. Normally, when I play this game in DOSBox, there
    is an extensive, funny sound when I die and when I jump and hit my
    helmet on the upper level there is a kind of 'dink' sound. Those two
    sounds don't play on the Windows 98SE box even though when I installed
    the included drivers from the accompanying CD with the DOS drivers too.

    My son and I noticed that even in a Windows game he used to play, some
    of the sounds are absent, like the background music sounds.

    I thought I read something online about PCI vs ISA and that I might have trouble getting this to fully work in DOS. But, I don't understand why
    if the CD that came in the box with the SB 16 PCI card had the option by default to install the DOS drivers too, not just Windows drivers.

    Any way, if anyone has any ideas I would appreciate it.

    Oh, in the DOS game there is no option to configure the sound card
    beyond picking Sound Blaster or Adlib, that's it.

    Thanks all!!




    ~Elf

    ,---------------------------,
    | /---------------------\ |
    | | | |
    | | Long Live | |
    | | DOS!! | |
    | | | |
    | | | |
    | \_____________________/ |
    |___________________________|
    ,---\_____ [] _______/------,
    / /______________\ /|
    /___________________________________ / | ___
    | | | )
    | 486DX66 [-------] | | (
    | o o o [-------] | / _)_
    |__________________________________ |/ / /
    /-------------------------------------/| ( )/
    /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ... DOS never says "EXCELLENT command or filename"...
    ___ Blue Wave/386 v2.30
    --- SBBSecho 3.14-Win32
    * Origin: Diamond Mine Online BBS 21:1/194 bbs.dmine.net:24 (21:1/194)
  • From acn@21:3/127.1 to Elf on Sun Jul 25 13:09:00 2021
    Am 24.07.21 schrieb Elf@21:1/194 in FSX_RETRO:

    Hallo Elf,

    I am wondering if anyone might have some ideas on getting a Sound
    Blaster 16 PCI card working fully in DOS. Here is what I have and what
    I'm trying to do.

    Dell Dimension 3000, 512MB RAM
    GeForce FX 5500 256MB video card
    Windows 98SE
    Sound Blaster 16 PCI with full software/drivers
    [...]

    Just to understand your setup:
    - do you try to run the games in pure DOS or in a Win98 DOS window/
    fullscreen session?
    - I don't know if it only applies to ISA-PNP card or also to PCI:
    Is a PNP configuration manager program installed which applies all
    ressources to the card after bootup? (Interrupts, IO ports etc.)
    - Does the DIAGNOSE tool from the SoundBlaster driver set output digital sounds and also MIDI sounds? The first part would provide sound effects in games and the other part provides music, usually.
    - Is the BLASTER variable set correctly?
    - Which sound card settings are active in the game?

    I guess these are the settings I remember :)

    Regards,
    Anna
    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (21:3/127.1)
  • From TALIADON@21:3/138 to Elf on Sun Jul 25 14:01:37 2021
    Hi Elf,

    Just a shot in the dark, but is the blaster variable set correctly within
    your AUTOEXEC.BAT file?

    For example:

    SET BLASTER=A220 I5 D1 H5 P330 E620 T6

    This tells DOS to use (Address 220, IRQ 5, DMA 1, HighDMA 5, MIDI Address
    330, EMU8000 Address 620, Card Type 6).

    Best Regards

    |01|09 |01|09 Lee Westlake |01(aka TALIADON)
    |09|01|09|01|09 |01|09 TALIADON BBS |01(taliadon.ddns.net)
    |09|01 E-Mail: taliadon-bbs@mail.com
    |09|01 fsxNet: 21:3/138 FidoNet: 2:250/6
    --- Mystic BBS v1.12 A46 2020/08/26 (Windows/32)
    * Origin: TALIADON BBS (21:3/138)
  • From Elf@21:1/194 to ACN on Sun Jul 25 21:44:00 2021
    Quoting Acn to Elf <=-

    Just to understand your setup:
    - do you try to run the games in pure DOS or in a Win98 DOS window/ fullscreen session?

    I have tried in full screen from Windows 98 and I have tried booting
    and pressing F8 and selecting command prompt only. In both scenarios the
    sound issue is the same.

    - I don't know if it only applies to ISA-PNP card or also to PCI:
    Is a PNP configuration manager program installed which applies all ressources to the card after bootup? (Interrupts, IO ports etc.)

    When I select restart in DOS it loads the drivers for DOS.

    - Does the DIAGNOSE tool from the SoundBlaster driver set output
    digital sounds and also MIDI sounds? The first part would provide
    sound effects in games and the other part provides music, usually.

    There is no DIAGNOSE tool, but instead there is a SBTEST I can run. It
    tests fine both in Windows and from the DOS prompt for digital audio and
    MIDI audio.

    - Is the BLASTER variable set correctly?

    Yes, the blaster variable is declared properly too.

    - Which sound card settings are active in the game?

    The sound card settings are set for Adlib/Soundblaster for both audio
    and music.




    ~Elf

    ,---------------------------,
    | /---------------------\ |
    | | | |
    | | Long Live | |
    | | DOS!! | |
    | | | |
    | | | |
    | \_____________________/ |
    |___________________________|
    ,---\_____ [] _______/------,
    / /______________\ /|
    /___________________________________ / | ___
    | | | )
    | 486DX66 [-------] | | (
    | o o o [-------] | / _)_
    |__________________________________ |/ / /
    /-------------------------------------/| ( )/
    /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ... BorgDOS v5.0 - Assimilate Another? [Y/n]
    ___ Blue Wave/386 v2.30
    --- SBBSecho 3.14-Win32
    * Origin: Diamond Mine Online BBS 21:1/194 bbs.dmine.net:24 (21:1/194)
  • From Elf@21:1/194 to TALIADON on Sun Jul 25 21:45:00 2021
    Quoting Taliadon to Elf <=-

    Hi Elf,

    Just a shot in the dark, but is the blaster variable set correctly
    within your AUTOEXEC.BAT file?

    For example:

    SET BLASTER=A220 I5 D1 H5 P330 E620 T6

    Yeah, it was set by the Soundblaster driver installation.





    ~Elf

    ,---------------------------,
    | /---------------------\ |
    | | | |
    | | Long Live | |
    | | DOS!! | |
    | | | |
    | | | |
    | \_____________________/ |
    |___________________________|
    ,---\_____ [] _______/------,
    / /______________\ /|
    /___________________________________ / | ___
    | | | )
    | 486DX66 [-------] | | (
    | o o o [-------] | / _)_
    |__________________________________ |/ / /
    /-------------------------------------/| ( )/
    /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ... DOS means never having to live hand-to-mouse
    ___ Blue Wave/386 v2.30
    --- SBBSecho 3.14-Win32
    * Origin: Diamond Mine Online BBS 21:1/194 bbs.dmine.net:24 (21:1/194)
  • From TALIADON@21:3/138 to Elf on Mon Jul 26 17:03:27 2021
    Yeah, it was set by the Soundblaster driver installation.

    Yeah, I thought it may have.

    Does the setup utility have the option to test each part of your config (i.e. MIDI, DSP, etc)?

    If so, you could try changing some of the parameters and retesting (it sounds like either one of the chips is no longer functioning, or you have a setup conflict)?

    Best Regards

    |01|09 |01|09 Lee Westlake |01(aka TALIADON)
    |09|01|09|01|09 |01|09 TALIADON BBS |01(taliadon.ddns.net)
    |09|01 E-Mail: taliadon-bbs@mail.com
    |09|01 fsxNet: 21:3/138 FidoNet: 2:250/6
    --- Mystic BBS v1.12 A46 2020/08/26 (Windows/32)
    * Origin: TALIADON BBS (21:3/138)
  • From Elf@21:1/194 to TALIADON on Mon Jul 26 16:12:00 2021
    Quoting Taliadon to Elf <=-

    Yeah, I thought it may have.

    Does the setup utility have the option to test each part of your
    config (i.e. MIDI, DSP, etc)?

    It just lets you test the "digital voice" and MIDI. No other options.

    If so, you could try changing some of the parameters and retesting (it sounds like either one of the chips is no longer functioning, or you
    have a setup conflict)?

    I don't see any conflicts, at least as far as Windows 98 is concerned,
    there are no reported conflicts. It seems the software is doing it's
    job, but since we are seeing the same problem with Windows applications
    - missing sound - then I think I might have a faulty card. :-(




    ~Elf

    ,---------------------------,
    | /---------------------\ |
    | | | |
    | | Long Live | |
    | | DOS!! | |
    | | | |
    | | | |
    | \_____________________/ |
    |___________________________|
    ,---\_____ [] _______/------,
    / /______________\ /|
    /___________________________________ / | ___
    | | | )
    | 486DX66 [-------] | | (
    | o o o [-------] | / _)_
    |__________________________________ |/ / /
    /-------------------------------------/| ( )/
    /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / /-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/ / ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ... I am Paul Simon of Borg: Listen, to the sounds, of assimilation.
    ___ Blue Wave/386 v2.30
    --- SBBSecho 3.14-Win32
    * Origin: Diamond Mine Online BBS 21:1/194 bbs.dmine.net:24 (21:1/194)
  • From acn@21:3/127.1 to Elf on Tue Jul 27 13:18:00 2021
    Am 25.07.21 schrieb Elf@21:1/194 in FSX_RETRO:

    Hallo Elf,

    - Does the DIAGNOSE tool from the SoundBlaster driver set output
    digital sounds and also MIDI sounds? The first part would provide
    sound effects in games and the other part provides music, usually.

    There is no DIAGNOSE tool, but instead there is a SBTEST I can run. It tests fine both in Windows and from the DOS prompt for digital audio and MIDI audio.

    Okay, then the sound card is generally working, for both parts.

    - Is the BLASTER variable set correctly?

    Yes, the blaster variable is declared properly too.

    - Which sound card settings are active in the game?

    The sound card settings are set for Adlib/Soundblaster for both audio
    and music.

    Okay, weird.
    I did not fully get which part of music/effects is absent eg. in Commander Keen.

    Usually, games used the "MIDI" sounds for music and the PCM digital audio
    for effects.
    Have you tried the MIXERSET tool to change the volumes of the channels
    before launching a game?
    Did the game ask you for the I/O port, Interrupt and/or DMA channel of the sound card and did you enter them according to the configured values?

    Regards,
    Anna
    --- OpenXP 5.0.50
    * Origin: Imzadi Box Point (21:3/127.1)